México Payout Approval Rates Decrease

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted May 30, 2026 - 01:50 UTC

Investigating

We are currently observing decreased approval rates affecting payouts processed in the specified country.
The situation is being closely monitored, and we will provide further updates as additional information becomes available.

All PayRetailers services remain fully operational, and our teams are actively monitoring external networks while working to restore normal performance levels.
Posted May 30, 2026 - 00:03 UTC
This incident affected: Payouts.