Colombia PSE Decrease in Conversion Rates

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 06:12 UTC

Investigating

We want to inform you that Banco Nequi is presenting issues on their end, there are some intermittences in the approval of payments through PSE.
Our platform is fully operational.
We are closely monitoring the situation and as soon as we have any news we wil let you know.
Posted Feb 18, 2026 - 05:28 UTC
This incident affected: Payins.