The outage has been fully resolved, and all affected services have returned to normal operation.
Our teams, together with external partners, have verified consistent transaction stability and full restoration of payment performance.
We appreciate your patience and understanding throughout the incident.
Posted May 29, 2026 - 18:12 UTC
Monitoring
Mitigation measures have been implemented in coordination with our partners, and transaction processing is gradually recovering.
We are closely monitoring the situation to ensure full stability across all payment operations before marking the incident as resolved.
Posted May 29, 2026 - 16:25 UTC
Update
We are continuing to investigate this issue.
Posted May 27, 2026 - 18:12 UTC
Investigating
We are currently experiencing a critical outage affecting payins processed through the specified payment method. Our teams are actively investigating and working to restore service as a priority.
Further updates will be provided as soon as new information is available, including a final resolution notice once service is fully restored. PayRetailers platform remains operational. Monitoring of external networks and processing channels is ongoing to support recovery.