Africa - Payin Approval Rate Decrease

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 21:11 UTC

Investigating

We are currently observing a decreased payin approval rate affecting transactions processed through Africa payment methods.
The situation is being closely monitored, and we will provide further updates as additional information becomes available.

All PayRetailers services remain fully operational, and our teams are actively monitoring external networks while working to restore normal performance levels.
Posted Jun 19, 2026 - 17:31 UTC
This incident affected: Payins.