Colombia PSE Decrease in Conversion Rates

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 17:22 UTC

Identified

We have detected a decline in conversion rates for deposits via the specified payment method.
Our system continues to operate normally, and we are working closely with our partner to restore optimal conversion performance.
We’ll keep you updated on developments of our investigation and will confirm once conversion metrics have returned to expected levels.
Posted Nov 27, 2025 - 14:08 UTC
This incident affected: Payins.