Ecuador Payouts Decrease in Conversion Rates

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Nov 29, 2025 - 16:20 UTC

Investigating

We are currently observing a lower-than-normal conversion rate for payouts to the specified country.

Our payout engine remains fully functional, and we are engaged with our partners to accelerate resolution and return to our expected conversion rates in this country.

We’ll continue to provide updates and notify you the moment full payout conversion recovery is achieved.
Posted Nov 28, 2025 - 12:43 UTC
This incident affected: Payouts.