Argentina Payouts Critical Outage

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 05:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2025 - 05:46 UTC

Investigating

We are observing a critical outage impacting payouts to this region. Preliminary investigation suggests the issue stems from an external banking-network dependencies beyond our infrastructure.

Our internal systems remain stable, and we are actively engaging with our partners to expedite full recovery.
Further updates will follow until payout processing returns to normal performance.
Posted Nov 28, 2025 - 05:42 UTC
This incident affected: Payouts.